同花顺源动术指标公式_股票k线图

同花顺江恩三线操盘主图指标公式

  说明:根据短、中、长三线控制仓位。三线之上90%仓位、两线之上60%、一线之上30%、三线之下空仓。

    

  N:=9;

  M:=3;

  P:=2;

  AN1:=3;

  AN2:=6;

  AN3:=12;

  AN4:=24;

  AN5:=25;

  K:=34;

  Z:=3;

  RAV:=(CLOSE-LLV(LOW,N));

  RAV1:=(HHV(HIGH,N)-LLV(LOW,N));

  RAV2:=RAV/RAV1;

  RAV3 := (HIGH + LOW + CLOSE+REF(C,1)+O)/5;

  RAV4:=RAV2*100;

  RAV5:=SMA(RAV4,M,1);

  RAV6:=SMA(RAV5,M,1);

  RAV7:=SUM(IF(RAV3》REF(RAV3,1),RAV3*VOL,0),N)/SUM(IF(RAV3《REF(RAV3,1),RAV3*VOL,0),N);

  资金:=100-(100/(1+RAV7));

  价格趋势:=(M*RAV5-P*RAV6)*1.1;

  A1:=EMA(CLOSE,7)-EMA(CLOSE,21);

  B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);

  短多:=IF(A1》=B1,A1,B1);

  短空:=IF(B1-A1,B1,A1);

  庄:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

  散:=EMA(100*(INDEXC-LLV(INDEXL,K))/(HHV(INDEXH,K)-LLV(INDEXL,K)),Z);

  V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);

  :=EMA(V11,3);

  VUAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH》LOW+0.04,4,0);

  乾坤:=IF(VUAR10*20 AND ((庄《15 AND 散《15) OR 趋势线《15),80,0);

  漂前探:IF(CROSS(价格趋势,资金趋势) AND SUM(乾坤,10)》50 AND BETWEEN(资金趋势,20,80),100,0),colormagenta;

  DRAWTEXT(漂前探=100 AND 庄》=REF(庄,1)*3,145,‘超强’),colorgreen;

  DRAWTEXT(漂前探=100 AND 庄《REF(庄,1)*3 AND 庄》REF(庄,1)*2,145,‘强’),colorgreen;

  动力: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),13,1),COLOR0000FF;

  底:=0;

  牛线:50,coloryellow;

  VGar3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

  AA:=((MA(CLOSE,AN1)+MA(CLOSE,AN2)+MA(CLOSE,AN3)+MA(CLOSE,AN4))/4);

  BB:=MA(CLOSE,AN5),colorred,LINETHICK2;

  LPC := REF(CLOSE,1);

  :=SMA(MAX(CLOSE-LPC,0),6,1)/SMA(ABS(CLOSE-LPC),6,1)*100,;

  WR:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));

  WR反向:=(0-WR)-100;

  RSI买点:=RSI《20 AND RSI》REF(RSI,1);

  WR反向买点:=WR反向》-80 AND WR反向《REF(WR反向,1);

  T0:=BARSCOUNT(C)》12;

  T1:=C=LLV(C,12);

  T2:=RSI》LLV(RSI,12);

  T3:=RSI《21;

  TRSI:=T0 AND T1 AND T2 AND T3 AND C/HHV(C,120)《0.7;

  RSI成W底:=IF(REF(TRSI,1) AND C》REF(C,1),100,0);

  梁股:=RSI买点 AND WR反向买点;

  关注:=IF(RSI成W底 OR 梁股,150,0),STICK,LINETHICK3,colorred;

  STICKLINE(关注=150,50,0,5,0),,colorred;

  DRAWTEXT(FILTER(关注=150,10),70,‘关注’),colorwhite;

  P1:=EMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5);

  P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);

  P3:=CROSS(P2,P1);

  P4:=REF(P2,2)《REF(P2,1) AND P2《REF(P2,1);

  P5:=COUNT(P3,7)》0 AND P4;

  P6:=3*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1)-2*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1);

  P7:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

  MW:= EMA(P6,5);

  NU:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

  NU0:=SMA(NU,3,1);

  NU00:=SMA(NU0,3,1);

  NU10:=3*NU0-2*NU00;

  NU1:=EMA(3*NU0-2*NU00,4);

  NU2:=SMA(NU1,5,1);

  NW:=MA(3*SMA(P7,6,1)-2*SMA(SMA(P7,5,1),5,1),2);

  HW:=CROSS(NW,0) AND MW《56;

  DP:=IF(P5 AND COUNT(P5,5)=1,1,0);

  底弹辅:=IF((HW AND DP) OR ((CROSS(IF(P6《3 AND NU2《5 AND NW《4,1,0),0.5)) AND LLV(L,34)/HHV(H,144)《0.78),120,0),coloryellow;

  DRAWTEXT(底弹辅=120,80,‘底弹辅’),colorred;

  TYP:=(HIGH+LOW+CLOSE)/3;

  :=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

  CII背离:=IF(CROSS(-200,CCI) AND 趋势线《20 AND 动力《-15,90,0),LINETHICK1,colorgreen;

  DRAWTEXT(CII背离=90,60,‘←CI背离’),colorgreen;

  多头线:=EMA(C,1.5);

  空头线:=EMA(C,5);

  均衡线:=EMA(空头线,5);

  VF1:=COUNT(CROSS(多头线,均衡线),2)=1;

  VSARF2:=COUNT(CROSS(空头线,均衡线),2)=1;

  抄S底:=FILTER(VSARF1 AND VSARF2,2);

  VSAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

  VSAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

  买S进:=CROSS(VSAR2,MA(VSAR3,6));

  次仓:IF(抄S底 AND 买S进 AND 庄》REF(庄,1) AND 庄》散-10 AND SUM(乾坤,15)》0,150,0),STICK,LINETHICK3,colormagenta;

  DRAWTEXT(次仓=150 AND SUM(乾坤,15)》0,110,‘←追涨’),colormagenta;

  MAD1:=((MA(C,60)-L)/MA(C,20))*200-20;

  三成仓:IF(MAD1》50,150,00),colorred,LINETHICK2;

  DRAWTEXT(FILTER(MAD1》50,10),140,‘←三成区’),colorred;

  漂元库:IF(乾坤=80,150,0),STICK,LINETHICK5,coloryellow;

  FD1:=ZIG(3,15);

  阴雨天:=IF((FD1》 REF(FD1,1)),0,20);

  量:=IF(CROSS(0.9,1/VOL*1000》0.01 AND “.J”《0),1.5,0);

  绝底:=IF(L《=LLV(L,100),-1,0);

  初晴:=IF(COUNT(C/REF(C,1)《0.96,6)》=1 AND LAST(C《O,2,1) AND (REF(L,1)/REF(C,4)《0.85 OR L/REF(C,3)《0.85) AND C》O,1.2,0);

  雨虹:IF((阴雨天=0 AND 量 AND 初晴) OR (阴雨天=0 AND 量 AND 绝底) OR (阴雨天=0 AND 绝底 AND 初晴),50,0),coloryellow,LINETHICK2;

  STICKLINE(雨虹,150,100,2,0),colorred;

  STICKLINE(雨虹,100,50,5,0),COLOR00FF00;

  a1:=AMOUNT/VOL/1000;

  b2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

  d3:=SUM(AMOUNT,13)/a1/1000;

  e4:=DMA(b2,VOL/d3);

  高手:=(CLOSE-e4)/e4*1000;

  抄底:=IF(CROSS(抄底高手,-166) AND 散》REF(散,1) AND 庄》散-20,50,0),LINETHICK1,colorcyan;

  DRAWTEXT(抄底=50,-5,‘抄底’),colorcyan;

  HLM1:=MA(HHV(H,485),17);

  HLM2:=MA(HHV(H,222),17);

  HLM3:=MA(HHV(H,96),17);

  HLM4:=MA(LLV(L,485),17);

  HLM5:=MA(LLV(L,222),17);

  HLM6:=MA(LLV(L,96),17);

  HLM7:=MA((HLM1*0.558+HLM2*0.558+HLM3*0.558+HLM4*0.96+HLM5*0.96+HLM6*0.96)/6,17);

  HLM8:=MA((HLM1*0.55+HLM2*0.55+HLM3*0.65+HLM4*1.25+HLM5*1.23+HLM6*1.2)/6,17);

  HLM9:=MA((HLM1*0.68+HLM2*0.68+HLM3*0.68+HLM4*1.3+HLM5*1.3+HLM6*1.3)/6,17);

  HLM10:=MA((HLM7*3+HLM8*2+HLM9)/6*1.738,17);

  HLM11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;

  HLM12:=MA(IF(C*1.35《=HLM10,HLM11*10,HLM11/10),3);

  HLMH:=HHV(HLM12,30);

  预涨:=MA(IF(L《=LLV(L,13),(HLMH+HLM11*2)/2,0),3)/200;

  漂铁卖:IF(PEAKBARS(3,15,1)=1,75,150),colorwhite,LINETHICK1;

  DRAWTEXT(漂铁卖=75,140,‘漂铁卖’);

(股票资源馆lixiangluntan.com)

【股票资源馆】让数据触手可得!专业和谐破解高端炒股软件!

是国内最好的股票软件、股票公式指标、股票书籍下载网站;提供最全面的股票知识、炒股教程、黑马股票、股票资讯、期货外汇等给大家在线参考学习。

同花顺三人行指标公式

  CG:MA(C,10),coloryellow,linethick2;

新版大智慧策略投资终端破解版-支持沪深L2行情-全推数据

下载地址:https://pan.baidu.com/s/1ElsbiZVo22G3Y8zHIUSGNg 提取码:1pok

备注:程序有32位和64位 如果你电脑是32位操作系统只能用32位程序, 如果你电脑是64位操作系统可以用32位程序和64位程序 程序加壳有的杀毒会误报,放过即可获设置信任。