通达信公式:DMI 经典选股公式_大智慧365破解版,股票

通达信买底卖顶股票指标公式

   买底卖顶

    

  在管理器中,条件选股中新建选股公式如下:

  参数 最小 最大 缺省

  N 2 90 14

  M 2 60 6

  HD:=HIGH-REF(HIGH,1);

  LD:=REF(LOW,1)-LOW;

  DMP:=EXPMEMA(IF(HD》0&&HD》LD,HD,0),N);

  DMM:=EXPMEMA(IF(LD》0&&LD》HD,LD,0),N);

  PDI:=DMP*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

  MDI:= DMM*100/EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

  ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

  ADXR:=EXPMEMA(ADX,M);

  CAI:=PDI-MDI;

  X:PDI》32 AND ADX》ADXR AND CAI》20 AND ADX《40 AND ADXR《40;

  1.MDI在PDI和ADXR之下,下破ADX

  TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

  HD :=HIGH-REF(HIGH,1);

  LD :=REF(LOW,1)-LOW;

  DMP:=EXPMEMA(IF(HD》0&&HD》LD,HD,0),N);

  DMM:=EXPMEMA(IF(LD》0&&LD》HD,LD,0),N);

  PDI: =DMP*100/TR;

  MDI: =DMM*100/TR;

  ADX: =EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

  ADXR:=EXPMEMA(ADX,M);

  Xg:mdi

  穿三线的选股

  TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

  HD :=HIGH-REF(HIGH,1);

  LD :=REF(LOW,1)-LOW;

  DMP:=EXPMEMA(IF(HD》0&&HD》LD,HD,0),N);

  DMM:=EXPMEMA(IF(LD》0&&LD》HD,LD,0),N);

  PDI:=DMP*100/TR;

  MDI:=DMM*100/TR;

  ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

  ADXR:=EXPMEMA(ADX,M);

  买点:(CROSS(PDI, MDI)AND CROSS(PDI, ADX)AND CROSS(PDI, ADXR))AND CLOSE》OPEN

  AND C/REF(C,1)》0.5 AND VOL》MA(VOL,5)*1.5,COLORRED,LINETHICK3;

  TR := SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);

  HD := HIGH-REF(HIGH,1);

  LD := REF(LOW,1)-LOW;

  DMP:= SMA(IF(HD》0 AND HD》LD,HD,0),7,1);

  DMM:= SMA(IF(LD》0 AND LD》HD,LD,0),7,1);

  PDI: DMP*100/TR,colorwhite;

  MDI: DMM*100/TR,coloryellow;

  ADX: SMA(ABS(MDI-PDI)/(MDI+PDI)*100,7,1),colorff00ff;

  ADXR:(ADX+REF(ADX,7))/2,color00ff00

  这是DMI公式

  取PDI》40,MDI《10,ADX》50条件选股公式

  PDI:=“DMI.PDI”;

  MDI:=“DMI.MDI”;

  ADX:=“DMI.ADX”;

  PDI》40 AND MDI《10 AND ADX》50

  发一个追涨的选股预警公式,原理:当DMI处于火箭升空时股价自5日线启动且红柱小于100,盘中实时预警出现后可追涨,注意不可满仓!文件我不会导出望有朋友指教。以下是源码:

  去除ST:=EXIST(C/REF(C,1)》1.055,60);

  去除停牌:=DYNAINFO(4)》0;

  XG:=去除ST AND 去除停牌;

  TR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),7,1);

  HD:=HIGH-REF(HIGH,1);

  LD:=REF(LOW,1)-LOW;

  DMP:=SMA(IF(HD》0 AND HD》LD,HD,0),7,1);

  DMM:=SMA(IF(LD》0 AND LD》HD,LD,0),7,1);

  PDI:=DMP*100/TR;

  MDI:=DMM*100/TR;

  ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,7,1);

  ADXR:=(ADX+REF(ADX,6))/2;

  (PDI》MDI) AND (PDI》ADX) AND (ADX》ADXR) AND(ADX》MDI) AND

  (PDI》ADXR) AND C》=(MA.MA1)*1.005

  AND VOL》REF(VOL,1) AND

  (LOW《=(MA.MA1)) AND (MA.MA1)》(MA.MA2) AND (DYNAINFO(17))》1 AND

  (C《30) AND(FINANCE(7)《300000000)AND (MACD.MACD》0) AND(KDJ.J)《100

(股票资源馆lixiangluntan.com)

【股票资源馆】同花顺实时港股破解,同花顺财富主力破解,大智慧财富破解版,通达信财富破解版,通达信专业版破解,通达信研究版破解,通达信超赢版破解,股票公式,股票指标公式,股票公式大全,指南针软件破解,炒股书籍,k线图怎么看,股票k线图,。

通达信参考底部股票指标公式

   参考

新版大智慧策略投资终端破解版-支持沪深L2行情-全推数据

下载地址:https://pan.baidu.com/s/1ElsbiZVo22G3Y8zHIUSGNg 提取码:1pok

备注:程序有32位和64位 如果你电脑是32位操作系统只能用32位程序, 如果你电脑是64位操作系统可以用32位程序和64位程序 程序加壳有的杀毒会误报,放过即可获设置信任。