通达信公式:新宝塔线指标源码_东方财富投资大师破解版

通达信宝塔线主图指标公式

   宝塔线主图

    

  所谓右侧交易者是指等。图形和价格变动以后才操作的人,右侧交易者从不预测后面会怎么样,只做现在该做的事。不受周边环境的影响,客观理智的跟随走势而行动。新宝塔线的特性就是很适合右侧交易者的工具。

  对技术,大家要有理性的认识。因为它们大多是以价格或量为基础而编写的。这就决定了它的滞后性和可改变的随意性。既不是万能的,也不会有100%准确率。但是,做为市场弱势群体的小散,指标却又是偶们唯一能简单上手的武器,那怕就是根木棍也比赤手空拳好些吧!

  对于偶来说,偶认为指标的最大定义是:能用简单的方法找到上涨或下跌的共同性。如:“股票上涨或下跌,必会上穿或跌破5日。”虽说有了共性也不见的就会走出一样的走势。可是这毕竟增大了操作的概率的胜率。当配合基本的量能和上的共性后,胜率不是就大的多了吗?有些朋友进入股市,喜欢研究各式各样的指标。到最后却因为掌握了太多的武器,事到临头反而不知道使用那种武器好了,所以会千种不如精一门。

  好的指标公式只要有两个功能就可运用于实战,配合量能,K线,加上一些资金的管理运用,你就可以在股市多赚少亏。

  第一个功能是能确定股票现行的方向。

  第二个功能是可以轻松的找到买卖点。

  而新宝塔线就具备这样的两大功能。

  方向:价在多空线上,多空线紫色该股现在正处于上行趋势,入场操作。

  价在多空线下,多空线蓝色该股现在正处于下跌趋势,场外观望。

  买卖点:三平底买进,三平顶。黄托底买进,绿压顶卖出。配合XMA线 使用。

  宝塔线分析要点;

  (1)宝塔线翻红之后,股价后市总要延伸一段上升行情。

  (2)宝塔线翻青之后,股价后市总要延伸一段下降行情。

  (3)盘局时宝塔线的小翻红,小翻青,可依设定损失点或利润点之大小而决定是否进出。

  (4)盘局或高档时宝塔线长青而下,应即获利了结,将手中持股卖出;反之,翻红而上,则是介入时机。(5)宝塔线翻青下跌一段后突然翻红,须防范为假突破之现象,不可马上抢进,须察3天。

  【均K线组合规则】宝塔线红色且5天均线上行,看多做多(可追多,不惜帮庄家抬轿)

  宝塔线红色但5天均线走平或下行,看多不做多(有筹码的继续与狼共舞,没筹码的观望不进)

  宝塔线绿色且5天均线下行,看空做空(对准接盘杀跌,不计盈亏)

  宝塔线绿色但5天均线走平或上行,看空不做空(没筹码的观望不进,有筹码的即使套牢也暂不割肉)。这样操盘心态极佳。

  【宝塔线指标用法】黄托底买进。绿压顶卖出。

  宝塔线1

  MA:ma(c,5),COLORWHITE;

  x:=(3*c+l+o+h)/6;

  多空线:(20*x+19*ref(x,1)+18*ref(x,2)+17*ref(x,3)+16*ref(x,4)+15*ref(x,5)+14*ref(x,6)

  +13*ref(x,7)+12*ref(x,8)+11*ref(x,9)+10*ref(x,10)+9*ref(x,11)+8*ref(x,12)

  +7*ref(x,13)+6*ref(x,14)+5*ref(x,15)+4*ref(x,16)+3*ref(x,17)+2*ref(x,18)+

  ref(x,20))/210,colorff00ff,linethick1;

  STICKLINE(REF(多空线,1)《多空线,多空线,REF(多空线,1),3,1),COLORRED;

  STICKLINE(REF(多空线,1)》多空线,多空线,REF(多空线,1),3,1),COLORCYAN;

  {用法:黄托底买进,绿压顶买出。}

  var1:=CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2);

  var2:=REF(var1,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var3:=REF(var2,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var4:=REF(var3,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var5:=REF(var4,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var6:=REF(var5,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var7:=REF(var6,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var8:=REF(var7,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var9:=REF(var8,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  varA:=REF(var9,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  varB:=REF(varA,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  varC:=REF(varB,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

  var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),4,1),COLORRED;{红1}

  varD:=CLOSE

  varE:=REF(varD,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  varF:=REF(varE,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var10:=REF(varF,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var11:=REF(var10,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var12:=REF(var11,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var13:=REF(var12,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var14:=REF(var13,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var15:=REF(var14,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var16:=REF(var15,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var17:=REF(var16,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var18:=REF(var17,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

  var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),4,0),COLORFFCC66;

  var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

  var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,1),COLORYELLOW;

  var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

  var8 OR var9 OR varA OR varB OR varC,1) AND varD;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,2),Color00ff00{98FD};

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),5,0),COLOR00ffff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR00c8ff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ecff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR10ffff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR10f0ff;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),5,0),COLOR00d900;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR93ffd1;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR93ff22;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLOR24ff22;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090ff2;

  宝塔线指标2

  var1:=CLOSE》REF(CLOSE,1) AND CLOSE》REF(CLOSE,2);

  var2:=REF(var1,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var3:=REF(var2,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var4:=REF(var3,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var5:=REF(var4,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var6:=REF(var5,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var7:=REF(var6,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var8:=REF(var7,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var9:=REF(var8,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  varA:=REF(var9,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  varB:=REF(varA,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  varC:=REF(varB,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  STICKLINE(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

  var8 OR var9 OR varA OR varB OR varC,CLOSE,REF(CLOSE,1),6,1),COLORRED;{红1}

  varD:=CLOSE

  varE:=REF(varD,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  varF:=REF(varE,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var10:=REF(varF,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var11:=REF(var10,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var12:=REF(var11,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var13:=REF(var12,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var14:=REF(var13,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var15:=REF(var14,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var16:=REF(var15,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  var17:=REF(var16,1) AND CLOSE《=REF(CLOSE,1) AND CLOSE》=REF(CLOSE,2);

  var18:=REF(var17,1) AND CLOSE》=REF(CLOSE,1) AND CLOSE《=REF(CLOSE,2);

  STICKLINE(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

  var14 OR var15 OR var16 OR var17 OR var18,CLOSE,REF(CLOSE,1),6,0),COLOR00d900{FFCC66};

  var19:=REF(varD OR varE OR varF OR var10 OR var11 OR var12 OR var13 OR

  var14 OR var15 OR var16 OR var17 OR var18,1) AND var1;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),6,1),COLORYELLOW;

  var1A:=REF(var1 OR var2 OR var3 OR var4 OR var5 OR var6 OR var7 OR

  var8 OR var9 OR varA OR varB OR varC,1) AND varD;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),6,2),Color00ff00{98FD};

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),8,0),COLOR00ffff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),6,0),COLOR00c8ff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLOR10ecff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ffff;

  STICKLINE(var19,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR10f0ff;

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),8,0),COLORff50ff{00d900};

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),6,0),COLORff50ff{93ffd1};

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),4,0),COLORff50ff{93ff22};

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORff50ff{24ff22};

  STICKLINE(var1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLORff50ff{090ff2};

  红色持股:0,COLORRED,LINETHICK0,PRECIS0;

  晶红卖出:var1A,COLORFF50FF,LINETHICK0,PRECIS0;

  绿色持币:0,COLOR00d900,LINETHICK0,PRECIS0;

  黄色:var19,COLOR00ffff,LINETHICK0,PRECIS0;

  宝塔线指标3

  XMA:ma(c,5),COLORWHITE;

  DD5:=XMA

  PARTLINE(XMA,DD5),color00FF00;

  x:=(3*c+l+o+h)/6;

  多空线:(20*x+19*ref(x,1)+18*ref(x,2)+17*ref(x,3)+16*ref(x,4)+15*ref(x,5)+14*ref(x,6)

  +13*ref(x,7)+12*ref(x,8)+11*ref(x,9)+10*ref(x,10)+9*ref(x,11)+8*ref(x,12)

  +7*ref(x,13)+6*ref(x,14)+5*ref(x,15)+4*ref(x,16)+3*ref(x,17)+2*ref(x,18)+

  ref(x,20))/210,colorff00ff,linethick1;

  三平底买入:var19,COLOR00ffff,LINETHICK0,PRECIS0;

  三平顶卖出:var1A,COLORFF50FF,LINETHICK0,PRECIS0;

  {DRAWICON(var19=1 ,REF(CLOSE,1) ,7 );

  DRAWICON(var1A=1 ,REF(CLOSE,1) ,8 );}

  {用法:黄托底买进,绿压顶买出。}

  DD:=多空线

  PARTLINE(多空线,DD),colorblue,linethick3;

  A:=(XMA》多空线);

  PARTLINE(多空线,A),COLORYELLOW,POINTDOT;

  A1:=(XMA《多空线);

  PARTLINE(多空线,A1),COLORWHITE;

  v1:=CLOSE*VOL;

  v2:=EMA(v1,13)/EMA(VOL,13);

  CYS:=(EMA((CLOSE-v2)/v2,1)*100);

  AA:=CYS;

  MIDD:=MA(CYS,20);

  CC:=MIDD+0.85*STD(CYS,10);

  tM6:=AA》CC;

  PARTLINE(XMA,tM6),colorred,linethick2;

  宝塔线3

  收盘价格:C,POINTDOT;

  ma5:ma(c,5);

  ma10:ma(c,10);

  ma20:ma(c,20);

  ma40:ma(c,40);

  ma60:ma(c,60);

  ma120:ma(c,120);

  B0:=REF(C-O,2);B1:=REF(C,1);B2:=REF(C,2);B3:=REF(C,3);B4:=REF(C,4);

  CMAX:=MAX(MAX(MAX(C,B1),B2),B3);CMIN:=MIN(MIN(MIN(C,B1),B2),B3);

  STICKLINE(C=CMAX AND (B1》=B2 OR B1》=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN)

  AND C》=B2 OR

  B2=CMAX AND B3=CMIN AND C》=B1 OR B3=CMAX AND C》=B1 AND C》=B2,B1,C,5,1),COLORRED;

  STICKLINE(C=CMAX AND B1=CMIN,B2,C,5,1),COLORRED;

  STICKLINE(C=CMIN AND (B1

  B2=CMIN AND B3=CMAX AND C

  STICKLINE(B1=CMAX AND C=CMIN,B2,C,5,0),COLORGREEN;

  STICKLINE(B1=CMIN AND C》=B2 OR (B2=CMIN AND B1《=B3 OR

  B3=CMIN AND B1《=B2) AND B2=B1,B1,B2,5,0),COLORGREEN;

  STICKLINE(B1=CMAX AND CB3 OR

  B3=CMAX AND B1》B2) AND B2》=B4 AND C

  宝塔线(精)4

  B1:=REF(CLOSE,1);B2:=REF(CLOSE,2);B3:=REF(CLOSE,3);B4:=REF(CLOSE,4);

  CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);

  STICKLINE(CLOSE=CMAX AND (B1》=B2 OR B1》=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE》=B2 OR

  B2=CMAX AND B3=CMIN AND CLOSE》=B1 OR B3=CMAX AND CLOSE》=B1 AND CLOSE》=B2,B1,CLOSE,8,0),COLOR000099;

  STICKLINE(CLOSE=CMAX AND (B1》=B2 OR B1》=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE》=B2 OR

  B2=CMAX AND B3=CMIN AND CLOSE》=B1 OR B3=CMAX AND CLOSE》=B1 AND CLOSE》=B2,B1,CLOSE,5,0),COLOR0000BB;

  STICKLINE(CLOSE=CMAX AND (B1》=B2 OR B1》=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE》=B2 OR

  B2=CMAX AND B3=CMIN AND CLOSE》=B1 OR B3=CMAX AND CLOSE》=B1 AND CLOSE》=B2,B1,CLOSE,3,0),COLOR0000FF;

  STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,8,0),COLOR000099;

  STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,5,0),COLOR0000BB;

  STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,3,0),COLOR0000FF;

  STICKLINE(CLOSE=CMIN AND (B1

  B2=CMIN AND B3=CMAX AND CLOSE

  STICKLINE(CLOSE=CMIN AND (B1

  B2=CMIN AND B3=CMAX AND CLOSE

  STICKLINE(CLOSE=CMIN AND (B1

  B2=CMIN AND B3=CMAX AND CLOSE

  STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,8,0),COLOR009900;

  STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,5,0),COLOR00BB00;

  STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,3,0),COLOR00FF00;

  STICKLINE(B1=CMIN AND CLOSE》=B2 OR (B2=CMIN AND B1《=B3 OR

  B3=CMIN AND B1《=B2) AND B2=B1,B1,B2,8,0),COLORFF9900;

  STICKLINE(B1=CMIN AND CLOSE》=B2 OR (B2=CMIN AND B1《=B3 OR

  B3=CMIN AND B1《=B2) AND B2=B1,B1,B2,5,0),COLORFFBB00;

  STICKLINE(B1=CMIN AND CLOSE》=B2 OR (B2=CMIN AND B1《=B3 OR

  B3=CMIN AND B1《=B2) AND B2=B1,B1,B2,3,0),COLORFFFF00;

  STICKLINE(B1=CMAX AND CLOSEB3 OR

  B3=CMAX AND B1》B2) AND B2》=B4 AND CLOSE

  STICKLINE(B1=CMAX AND CLOSEB3 OR

  B3=CMAX AND B1》B2) AND B2》=B4 AND CLOSE

  STICKLINE(B1=CMAX AND CLOSEB3 OR

  B3=CMAX AND B1》B2) AND B2》=B4 AND CLOSE

  宝塔线5

  B1:=REF(CLOSE,1);

  B2:=REF(CLOSE,2);

  SS:=IF(CLOSE》REF(CLOSE,1)&&REF(CLOSE,1)》=REF(CLOSE,2),1,IF(CLOSEREF(CLOSE,2)&&REF(CLOSE,2)》REF(CLOSE,1),2,IF(CLOSE

  SM:=IF(REF(SS,1)《》0,REF(SS,1),IF(REF(SS,2)《》0,REF(SS,2),IF(REF(SS,3)《》0,REF(SS,3),IF(REF(SS,5)《》0,REF(SS,5),IF(REF(SS,6)《》0,REF(SS,6),IF(REF(SS,7)《》0,REF(SS,7),0))))));

  MC:IF(REF(SS,1)《》0,B2,IF(SM》0,MIN(B1,B2),MAX(B1,B2))),COLORBLUE;

  STICKLINE(SS=1||(SM》=1&&SS=0),B1,CLOSE,COLORRED,1);

  STICKLINE(SS=-1||(SM《=-1&&SS=0),B1,CLOSE,COLORCYAN,0);

  STICKLINE(SS=2,B2,CLOSE,COLORRED,1);

  STICKLINE(SS=-2,B2,CLOSE,COLORCYAN,0);

  STICKLINE((SS=-1||SS=-2)&&SM》0,B2,B1,COLORRED,1);

  STICKLINE((SS=1||SS=2)&&SM《0,B2,B1,COLORCYAN,0);

(股票资源馆lixiangluntan.com)

【股票资源馆】让数据触手可得!专业和谐破解高端炒股软件!

是国内最好的股票软件、股票公式指标、股票书籍下载网站;提供最全面的股票知识、炒股教程、黑马股票、股票资讯、期货外汇等给大家在线参考学习。

股票指标公式之攻击力度

   : 公式之攻击力度

新版大智慧策略投资终端破解版-支持沪深L2行情-全推数据

下载地址:https://pan.baidu.com/s/1ElsbiZVo22G3Y8zHIUSGNg 提取码:1pok

备注:程序有32位和64位 如果你电脑是32位操作系统只能用32位程序, 如果你电脑是64位操作系统可以用32位程序和64位程序 程序加壳有的杀毒会误报,放过即可获设置信任。