通达信北沙画线副图源码免费指标公式_k线图

通达信公式:DMI 经典选股公式

  在 管理器中,条件选股中新建选股公式如下:

    

  北沙画线副图源码免费

  DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIF,9);

  :=(DIF-DEA)*2,COLORSTICK;

  SA:=INTPART(MACD*100+0.5)/100,COLORYELLOW,NODRAW;

  红天数:=IF(MACD》0,BARSLAST(CROSS(MACD,0)),DRAWNULL),COLORYELLOW,NODRAW;

  绿天数:=IF(MACD《0,BARSLAST(CROSS(0,MACD)),DRAWNULL),COLORCYAN,NODRAW;

  W1:STICKLINE(MACD》0,MACD,0,2.5,1),COLORRED;

  W2:STICKLINE(MACD《0,MACD,0,2.5,1),COLORCYAN;

  VA1:=HHVBARS(MACD,BARSLAST(MACD《0)+1);

  VA2:=CROSS(BACKSET(CROSS(0,MACD),REF(VA1,1)+2),0.5);

  QG:=DRAWLINE(VA2,MACD,REF(VA2,1),REF(MACD,1),1),COLORGREEN,DOTLINE;

  NOTEXT前高A:DRAWLINE(VA2,MACD,ISLASTBAR,REF(MACD,BARSLAST(VA2)),1),COLORWHITE,DOTLINE;

  VA3:=LLVBARS(MACD,BARSLAST(MACD》0)+1);

  VA4:=CROSS(BACKSET(CROSS(MACD,0),REF(VA3,1)+2),0.5);

  QD:=DRAWLINE(VA4,MACD,REF(VA4,1),REF(MACD,1),1),COLORYELLOW,DOTLINE;

  NOTEXT前低A:DRAWLINE(VA4,MACD,ISLASTBAR,REF(MACD,BARSLAST(VA4)),1),COLORWHITE,DOTLINE;

  W3:STICKLINE(MACD》QG,MACD,QG,1,0),COLORYELLOW;

  W4:STICKLINE(MACD《0 AND MACD《QD AND QD《0,MACD,QD,1,0),COLORBLUE;

  基准:=CONST(SUM(VA2,0));

  前高:=基准=SUM(VA2,0) AND VA2,COLORCYAN,NODRAW;

  前高1:=基准-1=SUM(VA2,0) AND VA2,COLORYELLOW,NODRAW;

  前高2:=基准-2=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高3:=基准-3=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  前高4:=基准-4=SUM(VA2,0) AND VA2,COLORWHITE,NODRAW;

  距离G1:=BARSLAST(前高1);

  距离G2:=BARSLAST(前高2);

  距离G3:=BARSLAST(前高3);

  距离G4:=BARSLAST(前高4);

  NOTEXTG2:DRAWLINE(前高1,MACD,前高 AND MACD》=REF(MACD,距离G1),MACD,0),COLORYELLOW;

  NOTEXTG1:DRAWLINE(前高1,MACD,前高 AND MACD《REF(MACD,距离G1),MACD,0),COLORGREEN;

  NOTEXTG3:DRAWLINE(前高2,MACD,前高1 AND MACD》=REF(MACD,距离G2),MACD,0),COLORYELLOW;

  NOTEXTG4:DRAWLINE(前高2,MACD,前高1 AND MACD《REF(MACD,距离G2),MACD,0),COLORGREEN;

  NOTEXTG5:DRAWLINE(前高3,MACD,前高2 AND MACD》=REF(MACD,距离G3),MACD,0),COLORYELLOW;

  NOTEXTG6:DRAWLINE(前高3,MACD,前高2 AND MACD《REF(MACD,距离G3),MACD,0),COLORGREEN;

  NOTEXTG7:DRAWLINE(前高4,MACD,前高3 AND MACD》=REF(MACD,距离G4),MACD,0),COLORYELLOW;

  NOTEXTG8:DRAWLINE(前高4,MACD,前高3 AND MACD《REF(MACD,距离G4),MACD,0),COLORGREEN;

  基准2:=CONST(SUM(VA4,0));

  前低:=基准2=SUM(VA4,0) AND VA4;

  前低1:=基准2-1=SUM(VA4,0) AND VA4;

  前低2:=基准2-2=SUM(VA4,0) AND VA4;

  前低3:=基准2-3=SUM(VA4,0) AND VA4;

  前低4:=基准2-4=SUM(VA4,0) AND VA4;

  距离D1:=BARSLAST(前低1);

  距离D2:=BARSLAST(前低2);

  距离D3:=BARSLAST(前低3);

  距离D4:=BARSLAST(前低4);

  NOTEXTD1:DRAWLINE(前低1,MACD,前低 AND MACD》=REF(MACD,距离D1),MACD,0),COLORYELLOW;

  NOTEXTD2:DRAWLINE(前低1,MACD,前低 AND MACD《REF(MACD,距离D1),MACD,0),COLORGREEN;

  NOTEXTD3:DRAWLINE(前低2,MACD,前低1 AND MACD》=REF(MACD,距离D2),MACD,0),COLORYELLOW;

  NOTEXTD4:DRAWLINE(前低2,MACD,前低1 AND MACD《REF(MACD,距离D2),MACD,0),COLORGREEN;

  NOTEXTD5:DRAWLINE(前低3,MACD,前低2 AND MACD》=REF(MACD,距离D3),MACD,0),COLORYELLOW;

  NOTEXTD6:DRAWLINE(前低3,MACD,前低2 AND MACD《REF(MACD,距离D3),MACD,0),COLORGREEN;

  NOTEXTD7:DRAWLINE(前低4,MACD,前低3 AND MACD》=REF(MACD,距离D4),MACD,0),COLORYELLOW;

  NOTEXTD8:DRAWLINE(前低4,MACD,前低3 AND MACD《REF(MACD,距离D4),MACD,0),COLORGREEN;

(股票资源馆lixiangluntan.com)

【股票资源馆】东方财富L2决策破解版,东方财富网,东方财富投资大师破解版,东方财富先锋版破解,东方财富领航版破解,同花顺远航版破解,同花顺财富先锋破解,同花顺L2破解。

通达信买底卖顶股票指标公式

   买底卖顶

新版大智慧策略投资终端破解版-支持沪深L2行情-全推数据

下载地址:https://pan.baidu.com/s/1ElsbiZVo22G3Y8zHIUSGNg 提取码:1pok

备注:程序有32位和64位 如果你电脑是32位操作系统只能用32位程序, 如果你电脑是64位操作系统可以用32位程序和64位程序 程序加壳有的杀毒会误报,放过即可获设置信任。