同花顺KD强弱指标公式_源码交流

同花顺交易机器人指标公式

  H1:EMA(C,8);

    

  介绍:KD指标表达的另一种形式 红绿柱代表K值,变色线代表D值 使用方法如下: 一、上升信号: 1,企稳信号:在0线出现的灰色三角,企稳信号是为防止调整后的再次上升, 但也有可能仅是反抽 2,低位启动:在0线出现的黄色三角 3,拐点信号:D线由蓝变红 4,突破信号:红柱突破D线 5,红柱信号:出现红柱 红线上方红柱是持股信号。二、下跌信号: 1,高位下跌:顶线出现绿色三角 2,绿柱信号:出现绿柱 3,击穿信号:绿柱击穿D线 4,拐点信号:D线由红变蓝 D线下方绿柱是持币信号 三,强弱区信号 考虑在强弱区出现的各种信号。

  N:=5;

  VAR2:=LLV(LOW,N);

  VAR3:=HHV(HIGH,N);

  rsv:=(CLOSE-VAR2)/(VAR3-VAR2)*100;

  K:SMA(rsv,3,1);

  D:SMA(K,3,1),colorblue;

  PARTLINE(D,D》REF(D,1),colorred,D《=REF(D,1),colorliblue),LINETHICK1;

  J:3*K-2*D,colorlired;

  {“K值柱状线”;}

  STICKLINE(K》REF(K,1),K ,REF(K,1),6,0),colorred;

  STICKLINE(K《=REF(K,1),K ,REF(K,1),6,0),colorgreen;

  {“强弱分区”;}

  顶:100,coloryellow;

  强势区:80,colorgray;

  强弱分界:50,coloryellow;

  弱势区:20,colorgray;

  底:0,colorred;

  {“信号”;}

  企稳:IF((K》REF(K,1)) AND (REF(K,1)《=REF(K,2)) AND (REF(K,2)《=REF(K,3)),5,0),colorgray;

  低位启动:IF((D》REF(D,1)) AND (REF(D,1)《=REF(D,2)) AND K《20,5,0),coloryellow;

  //DRAWICON(CROSS(K,D) AND K》REF(K,1) AND k》=20,REF(K,1)*0.96,1);

  {“信号”;}

  高位下跌:IF((D《REF(D,1)) AND (REF(D,1)》=REF(D,2)) AND K》80,95,100),colorgreen;

  //高位死叉:DRAWICON(CROSS(D,K) AND K《REF(K,1) AND K》80,REF(K,1)*1.1,6);

  //DRAWICON(CROSS(D,K) AND K《REF(K,1) AND K《=80,REF(K,1)*1.02,2);

(股票资源馆lixiangluntan.com)炒股教程

同花顺均线上的KDJ指标公式

  使用说明: 1,红柱持股,绿柱持币,白柱过渡 2,红箭头 多头,绿箭头均线空头 3,配合上方KD 。

新版大智慧策略投资终端破解版-支持沪深L2行情-全推数据

下载地址:https://share.weiyun.com/2Q1cScAz